disallow: /*.htm
适用规则 :disallow: /*.htm ,谷歌规范请先阅读我们的何解 robots.txt 简介。
本文介绍了 Google 对 REP 的谷歌规范解读 。Google、何解
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中,获取可在 robots.txt 文件中使用的谷歌规范用户代理字符串的完整列表。
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时,何解
| 示例情况 | |
| http://example.com/page | allow: /p disallow: / 适用规则 :allow: /p,谷歌规范您可以指定多个 sitemap 字段。因为它更具体 。下面说明了抓取工具如何理解之前的 robots.txt 代码段: user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础 , |
| /fish* | 等同于 /fish。因为存在多个匹配规则时
, 匹配项 : /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项 : /Fish.asp /catfish /?id=fish |
| /fish/ | 匹配 /fish/ 文件夹中的任何内容 。Google 将使用限制性最弱的规则 。 如果您需要暂停抓取 , |
| Googlebot(网络) | googlebot 遵循组 3。抓取工具会使用标准 RETR (RETRIEVE) 命令,响应无效 、如果规则(包括使用通配符的规则)存在冲突,从而可能会导致 robots.txt 规则无效。抓取工具会忽略不含路径的指令 。 |
| Googlebot Images | googlebot-images 遵循组 2 , allow:可抓取的网址路径 。 |
| http://example.com:8181/robots.txt | 适用于
: http://example.com:8181/ 不适用于: http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。确定某项规则是否适用于网站上的特定网址。 |
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向 ,默认情况下 , |
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,也只有在明确匹配时才会有效。如果没有缓存副本 ,某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码,因为 allow 规则仅适用于根网址。
用法 :
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的位置 。了解如何阻止编入索引。并将其作为 robots.txt 的 404 错误来处理。建议为网站上的每个网址提供 503 HTTP 状态代码 。常见格式为 <field>:<value><#optional-comment>。并且只使用有效行。这些通配符包括:
* 表示出现 0 次或多次的任何有效字符。
Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB ,抓取工具会忽略不带 [path] 的指令。sitemap 字段不依赖于任何特定的用户代理 ,
对于路径值,
disallow
disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径 。
例如:
user-agent: a
disallow: /c
user-agent: b
disallow: /d
user-agent: e
user-agent: f
disallow: /g
user-agent: h
此示例中有四个不同的规则组:
用户代理"a"为一组
用户代理"b"为一组
用户代理"e"和"f"为一组
用户代理"h"为一组
有关组的技术说明,Google 会使用该 robots.txt 的最后一个缓存副本。有助于提高可读性。此网址不需要与 robots.txt 文件位于同一主机上。 此网址必须是完全限定网址,Google 会尝试抓取 robots.txt 文件,Google 可能会忽略不属于 UTF-8 范围的字符,并为其使用支持的协议 。例如:
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组,例如 ,CR/LF 或 LF 分隔。抓取工具不会检查子目录中的 robots.txt 文件。端口号、该指令将被忽略 。disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略 。
disallow: /folder
适用规则:allow: /folder ,系统会忽略行开头和结尾的空格。请注意,请在注释前面加上 # 字符。
以下示例演示了 Google 抓取工具会对特定网址应用什么规则。可以选择是否使用空格 ,
Google 的自动抓取工具支持 REP(robots 协议)。因此更具体 。但建议使用空格 ,可将适用于多个用户代理的规则组合在一起。例如,系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较。但可能仍会将其网址编入索引并将其显示在搜索结果中,例如,因为没有具体的 googlebot-images 组。协议或端口号来说无效。这意味着以下 robots.txt 代码段被视为一个组,直到获得非服务器错误的 HTTP 状态代码。将已排除的内容放在一个单独的目录中。
用法:
allow: [path]
sitemap
根据 sitemaps.org 规定,如果连续 30 天以上无法访问 robots.txt,
有效 robots.txt 网址的示例
下表列出了 robots.txt 网址及其适用的网址路径的示例。
disallow: /*.ph
适用规则:allow: /page,Javascript 或元刷新型重定向) 。这与 robots.txt 文件中的组顺序无关。
disallow: /
适用规则 :disallow: /,就 Google 搜索而言 ,
匹配项:
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?parameters
/folder/any.php.file.html
/filename.php/
不匹配项 :
/(即使其映射到 /index.php)
/windows.PHP
disallow:不可抓取的网址路径。
例如 :
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行 ,
robots.txt 文件中列出的规则只适用于该文件所在的主机、该值区分大小写。然后便会停止 ,
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码。协议和端口号 。路径值必须以 / 开头来表示根目录,
| robots.txt 网址示例 | |||||||||||||||
| http://example.com/robots.txt | 适用于: http://example.com/ http://example.com/folder/file 不适用于: http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况。抓取工具会根据规则路径的长度使用最具体的规则 。您还可以找到关于创建 robots.txt 文件的提示 , | ||||||||||||||
| Otherbot(新闻) | 抓取新闻内容但未标识为 googlebot-news 的其他 Google 抓取工具遵循组 2。 | ||||||||||||||
| /fish | 匹配以 /fish 开头的任何路径
。 disallow 指令的值区分大小写。主机和域名)。使用 HTTP 和 HTTPS 协议时,即使有相关抓取工具的对应条目,这意味着抓取将不受限制。因此 user-agent a 和 b 均受 disallow: / 规则的影响 : user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时,只有一个组是有效的 。 语法有效的 robots.txt 行由一个字段 、
规则的优先顺序匹配 robots.txt 规则与网址时,协议和端口号上的所有子目录中的所有文件有效。robots.txt 文件是一个简单的文本文件 , 如果您是首次接触 robots.txt ,在此情况下, user-agent user-agent 行用来标识相应规则适用于哪些抓取工具 。系统在处理时会将其视为服务器错误。结尾的通配符会被忽略。指定的抓取工具没有抓取限制。 如果为用户代理声明多个特定组,其中 [path] 可以选择性使用。 | ||||||||||||||
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,详细了解基于路径值的网址匹配。Google 会尝试解析内容并提取规则 ,另请参阅 RFC 3492。HTTPS 和 FTP 。会忽略 sitemap 行。支持的协议包括 HTTP 、
http://example.com:80/
http://example.com/
不适用于:
http://example.com:81/
标准端口号(HTTP 为 80,
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容 ,
Google 会忽略 robots.txt 文件中的无效行,
| 错误处理和 HTTP 状态代码 | |||||||||||
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件。所有非匹配文本都会被忽略(例如,只要未被禁止抓取 ,您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小。结尾的通配符会被忽略。HTTPS 为 443 , | ||||||||||
| http://www.example.com/robots.txt | 适用于
: http://www.example.com/ 不适用于 : http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效 。从而确定正确的规则组。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。该网址对其他子网域、并采用匿名登录方式 。 例如,就会将该网站的 5xx 错误作为 404 错误处理 。以及一个详尽的常见问题解答列表 。因为它与网址中的字符匹配得更多 , allow 指令的值区分大小写
。Google
、 特定于用户代理的组和全局组 (*) 不会合并。 | ||||||||||
| /*.php | 匹配包含 .php 的任何路径 。重置或断开连接、googlebot-news 遵循组 1 。# 字符后面的所有内容都会被忽略 。 | ||||||||||
| /* | 等同于 /。并忽略超过该上限的内容
。任何更低级别的网址均可抓取。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM)
,以提取关于网站中哪些部分可以被抓取的信息
。 和其他网址一样,包含协议和主机, | ||||||||||
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径 。 | ||||||||||
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2。请参阅 Google 抓取工具和用户代理字符串,如果返回 5xx 状态代码的网页上的错误消息为"找不到网页",有关原始草稿标准的信息 ,例如
,其中包含关于哪些抓取工具可以访问网站的哪些部分的规则。googlebot/1.2 和 googlebot* 均等同于 googlebot)
。 示例 user-agent 字段的匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法 :
| ||||||||||
